Bug with hire and other buttons
Incident Report for Restaurant Streets
Resolved
This issue has been resolved
Posted Oct 30, 2020 - 17:34 UTC
Investigating
We are detected some problem with buttons un the game. Our team works to fix it
Posted Oct 30, 2020 - 17:06 UTC
This incident affected: Game platform.